CONTACT US

BE FIRST TO KNOW

Questions? Comments or like to contact us? Use this form to message us.

Email: sales@nexdome.com

Tel:    +1.604.421.2835

Sign up for our newsletter to get informed about NexDome news or new products.

Dec 1, 2018

The Provided Dome Power Supply is Faulty

13 comments

 

I have been posting off and on my observations looking at the ASCOM driver setup seeing that when the rotator is idle the indicated voltage will drop from ~12.5 to ~5V. Several other users on this forum have reported similar things and lots of esoteric ideas have floated about. In order for the dome to even function I've set the rotator low voltage to 0.5V.. Tonight I finally got around to replacing the provided "LY1205" 12V 5A power supply with a 12V 5A Mean Well power supply I got from Jameco. ~$29 US. First off the Mean well supply is the same physical size but weighs about 3 times more. Also, the 12V leads have wires which are shielded and at least 4xs heavier.

 

Bottom line is that with a proper power supply the driver indicated rotator voltage sits steady at 12.45V and never wavers. Another Nexdome user had "sendserial" errors which were in fact caused by a combination of this sorry to be blunt cheap power supply and bad solder joints.

 

I think the only reason I've had pretty solid performance is I use a high quality 12V powered USB hub. I hope my rant here helps some other person.. The only difficult thing is the center pin of the dome rotator 12V input is rather fat. The Mean well I bought has std 2.1mm pin and I had to cut the leads and replace.

 

Best to all,

Ron

Dec 1, 2018

Ron, based on all of the issues with the shutter motor from NexDome you would think that higher quality components would be used. I'm very reluctant to invest in the shutter based on many of the reported troubles and having to replace components.

 

I hope Babak is following this forum, I still monitor FB but I find it pretty terrible to follow a topic.

Dec 1, 2018

Hello Steve, I am running very reliable ACP-client completely automated imaging with good reliability. When I got my kit I looked and found/fixed a few simple things like PC board mounting screws being loose or missing. Just make sure the PC board has good solder joints and mounting bolts and it's likely pretty darn good. I have had no hardware failures. The biggest issue is the ASCOM driver is fragile and I had to carefully script around the issues. Once done it's great. The PDM firmware is pretty good with just a couple of very simple edits which are mostly about ensuring debugging is off else the ASCOM logs generate something like 4 GB of TEXT a night.

 

I'm really happy now for about 6 weeks of solid performance. I had to post the power supply note because I had stated it a number of times previously but never proven and inside other subjects. With the original plus failure to drop rotator voltage cutoff to like 0.5 V nothing would work. I had watched lots of traffic here talking about everything except the actual issue.. a "green" power supply which drops back to nothing when power not needed.

 

Best to you,

Ron

Dec 2, 2018

@Ron Crouch I posted my comment here because many folks on FB are still having issues with the shutter and rotator kits operating correctly, battery charging issues board swap outs etc.

 

I'm having basic issues with the dome rotation kit. I can't get the dome and mount to sync correctly. Sometimes its dead on but when I home the dome it goes home which lines up with Polaris. Since my mount has good PA, I use Pole Master, and when I turn on slave the dome moves past Polaris ~by 10 degrees. Other times when the dome is slaving to the mount the shutter opening its the mark then moves again with the same 10 degrees of error. I just uploaded the original firmware I got from Babak but now I'm having issues with com ports not seeing the mount, so once I fix that maybe it will work.

 

I was going to upload the PDM firmware but kept getting an error message in Arduino IDE. I contacted Pat who has not responded. Let me make this clear, I am not into any type of programing so cleaning up PDM is way beyond my talents.

 

To further confuse me it was also suggested that I use SGP which I've downloaded an run. SPG most likely will work when I get to a higher level of automation but not being able to get consistent dome slaving is causing me sleepless nights. I don't have a clue to what ACP is other than another observatory control program. If it's like SPG, which overwhelms me when I launch it, then all seems lost to me. Another program I guess I'll need is Dreamweaver for remote control. I've been on Cloudy Nights, who generally has great posts, and I've learned somethings about this but the subject just seems so vast it makes my head hurt just typing this reply.

 

I guess I wasn't prepared for all of this effort when all I wanted to do was take some nice DSO images from my backyard. I was getting used to PA, Automated Alignment and OAG but not really interested in sitting outside in the cold for hours at a time. Therefore, automated DSO was a topic so I started with a NexDome.

Dec 2, 2018

Hello Team. It get worse but with an simple solution. Not only was the provided power supply iffy - the cord has a ground lug on brick end but no ground on plug end!!! If I use that un-grounded power cord with my new good power supply at power up of dome all sorts of havoc break out. Each time a dance was needed to make the shutter talk.. Sometimes it would never work.

 

At one point .NET goes nuts with scary message basically saying I had no USB on the device. My volt meter showed a whopping ground loop between the grounds for power and usb.

 

I just put back a power cord which also has a grounding pin and everything is back working properly.

 

So everyone who is having flaky stuff going on simply replace the power cord with something which grounds and make darn sure your PC, it's accessories, and the dome power supply are from a common source.

 

I?'d wager a fine beer this simple stuff will solve a host of very scary issues. I would appreciate it if someone could share these last two power supply related posts on the FB group. I absolutely cannot do FB. Sorry but it's too insecure for the work I do.

 

Best,

Ron

Dec 3, 2018

Ron, I'll post a link to this thread on FB.

Thanks,

Steven

Dec 3, 2018

@Steven Green . Thank you Steve! I really must close my comments here underscoring how well this all works for me. I have no problem running sessions from far from home.. Opens up an hour before sunset and it closes at dawn parked on the shutter tabs. If the cloudwatcher senses overcast shutter closes parked on tabs until things clear. I sleep through it all.

 

Like I said there were very simple changes to firmware with the key one being in RotatorClass.h changing the Debuglevel from 1 to 0 on line 78. Also comment out line 686 by adding two //. This is 0.5.3.2,

 

One change to PDMShutterClass.h. Lines around 138 to 140 should be structured like this:

 

} Configuration;

Configuration config;

 

In 0.5.3.2 an initialization is needed where if the shutter is powered off when it comes back on the Rotator must be powered and then using the switch open the shutter a little then close til it stops at switches. Regarding the rotator.. each morning me shutdown script powers off both the USB hub it is connected to and the 12V rotator supply. Thus each night it all starts fresh. Best to leave shutter always on in my experience.

 

Having said all of this Rodolphe is doing brilliant work with a "2.0" version of this. I cannot transition yet because in my world the ASCOM driver is not quite there. What I have works great and travel prevents me from helping as I should with that.

 

Thanks again for posting on FB.

 

Best to all,

 

Ron

Dec 3, 2018

@Ron Crouch please keep monitoring this thread encase others have questions And need to tap your experience.

Dec 3, 2018Edited: Dec 3, 2018

 

 

I go way back one of the first with rotator and also with shutter. Rotator wasn't much of a problem but the shutter has been horrible. When it works ITS GREAT. But in the time I've owned it, it's not worked most of that time. Because of that I got about 4 months of imaging last year. Babak has been great at exchanges by shipping is costly and it doesn't stop down time. I just sent in the rotator and shutter and he swapped them out for newer models. All worked great but with winter clouds are here and I used it two nights. recently I went to demo the system for a friend considering buying a nexdome setup and the shutter wouldn't work (again). Symptoms are same as before. It can't retain the PDM driver settings, it displays wrong or no or part of teh version. It runs REAL SLOW. Holding the rocket switch to open starts with a very slow click... holding the button the clicking speeds up slowly over time. Releasing the rocket make the clicking start to slow and eventually stops. Data in the settings is lost and shows mostly zero's. Power shows random readings and on occasion 13.4v (which is accurate). Testing charger and battery always shots 13.4 v. I'm at wits end. I seem to spend more time repairing than imaging.

I haven't found any replies (help) to my problem posted on fb. I included photos of the random attempts to pull data from the driver. Yesterday I pulled the shutter so that I can at least image by going out to the dome (I'm normally fully remote from in the house). But now I have to walk out 300ft and manually open and again to close it. Since I had this same problem a few months ago. SURELY someone else has too and knows what I need to replace? I wish I could purchase more robust electronic parts which would be more tolerant of errors. I'm on win10 with Pats firmware. (I helped him create it as he had no hardware to test it on. So it would write it and I'd test and report back the problems). Now with that working well - I need to get past the problems in the shutter hardware!? - hoping someone here has the expertise. Attached are some of the driver displays I recieved. I entered in new settings for speed and set them, but next peek into the driver showed 0's. ODDLY the driver version is trunc'd. (where does it pull this data from? is is stored in the shutter or does it have to be loaded from the rotator? (via Xbee?)

 

 

 

 

 

 

 

 

Dec 3, 2018

P.S. I try to promote the dome sales as I really love it (when it works) but the biggest hurdle I find in trying to get people to buy them is the problems they read about and hear from currently owners with the rotator and shutter. I'm sure these items are REALLY reducing Nexdome sales. = ( A dozen people were watching the broadcast demo (on nightskiesnetwork.com) and learned that the shutter once again was not working. I could not open it or open the cap on the scope (shutters in the way) or demo tracking. Lots of guys interested in the nexdome were disillusioned. = (

Dec 3, 2018

I get what you're saying. I was aware of the issues with the shutter kit and I made the decision to still buy the NexDome. I understood that the shutter issues would be worked out eventually since there are a lot of really smart people on this forum. My dome is less than 100 feet from my back door so opening the shutter manually isn't a show stopper. for now. I do want to get to fully automating the dome so I can sleep through the night.

 

As you stated above many have been disillusioned by these failures. I've learned that the components to the rotation and shutter kit shouldn't be failing at the rate I'm seeing on this forum and FB. These items are pretty expensive and I don't believe that I, as a customer, need to do quality testing and paying for remedies that should come from the supplier and that includes shipping costs. When NexDome can state with assurance that all of the cheap parts have been upgraded and workmanship issues have been solved I'll get in line for the shutter kit.

 

I'm an end user and I need the equipment and software to work out of the box. I've suffered through Celestron's firmware updating problems, QHY's problems with Mac computers to the point I bought a Windows 10 PC (I really don't like Windows!) for my Pole Master. Yes, I admit that there is a lot of work to be dome going automated but that shouldn't include beta testing parts IMHO.

Dec 3, 2018

Mine is a hike and lots of critters out there in the pitch black. It is AWESOME being fully remote. (when it works). I went with nexdome as well- knowing that the only alternative to automation is going to be far more costly. Babak suggested sending me a stepper driver. (to swap in the shutter) crossing my fingers.

I just wish I understood how the things work so that I could better service my own problems.

Dec 15, 2018

So one thing I'd like to add to reinforce what Ron said here... the Mean Well power supply are of top quality .. proof ? .. Software Bisque ship Mean Well power supply with their mount (the 48V model).

This is probably the best approval we can get regarding the quality of the Mean Well power supply.

I ordered one from Amazon that has the right plug size hole for 2.5mm tip :

https://www.amazon.com/gp/product/B013EU4AHQ/ref=oh_aui_detailpage_o09_s00?ie=UTF8&psc=1

It works great and is very stable.

I you have the "bad" power supply I would recommend you buy one of these as a replacement.

New Posts
  • This is the process i go through to get to the speed settings for the shutter, so a few questions: First I open ascom dome control panel I click connect. Of course it doesnt let you change values unless its disconnected, so i disconnect and reopen the nexdome ascom server monitoring window, hit setup: Seems no matter what values i put below, here 600/1500 etc, the speed of the shutter is the same. I had tried lowering these at first to see if it would help with the motor sticking. Is this the right procedure to lower the values and test? Also, i know there is a much longer thread here about updating the firmware on the shutter/rotator, but, what does the update firmware button here do? At one point i clicked it when only the rotator was connected, it claimed it updated? How do i know if i even need to update either? Both came brand new recently? Thanks in advance
  • I've completed the motor install (although i may be missing parts on the motor related to this, the set key that holds the pin in place was missing, found an m4 for now that seems to hold it but the pin doesnt go in fully, see this thread for more details) https://www.nexdome.com/forum/observatory-automation/shutter-motor-missing-key-set-screw-locking-pin-wont-go-in-fully-track-shredding First issue (or maybe not), when i push the motor and it moves up, i think when the panel that has the band through it goes under the first panel, half way up, it sticks for a half second, flexes and pops and keeps going. After this at times on the way up, even during the first half, sometimes the motor stalls briefly. The biggest issue is after its up fully and you bring it down, the first 16" or so going back it stalls and moans repeatedly, however, interestingly i can work it forward by doing an on off real quick multiple times, OR by pressing upward on the motor. Here is a video clip of the stalling (most of it near the end): https://www.youtube.com/watch?v=nCtvALmB6zU At this point i took all the wheels off the rear, added washers, so now they have quite a bit of flex available. The retention bracket is installed, but i had my son work the motor while i pulled back on the bracket and wheel on one side only, no change. When you pull the panels in the rear when its up there, apart, you can see grinding marks on each panel on the sides. So at this point i'm left with removing the retention brackets on both sides as a final test, and to be able to get the panels apart to add antifriction tape someone recommended. It appears the front panels will need to come off (not the rear solid non moving one), then apply tape as here: Here is an external view of the situation: https://www.youtube.com/watch?v=rNHI3KzOkbw This is the antifriction tape i've ordered (1" x 15 feet, two rolls,TapeCase 423-5 UHMW) : https://www.amazon.com/gp/product/B00823JF0S/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 I dont know what else to try, other than what i have planned at this point. Pretty frustrated. Incidentally, i have the inside dome rotation working pretty solidly, so this is the only sticking point, pun intended. Thanks in advance.
  • Im breaking my shutter issues into multi parts here, in this one, i seem to be missing the set screw on the part by the gear as in this image: The part circled was naturally coming out. I'd like to get the official part to fix this, however in the meantime i've added what seems to mostly fit but not flush, m4 set screw and the locking pin goes in a tad further: Any suggestions here? From someone else, it appears that pin should slide all the way inside (i dont know if this could be related to the motor stalling/sticking issue i have (sep thread))