CONTACT US

BE FIRST TO KNOW

Questions? Comments or like to contact us? Use this form to message us.

Email: sales@nexdome.com

Tel:    +1.604.421.2835

Sign up for our newsletter to get informed about NexDome news or new products.

Nov 18, 2018

Dome motor controller power off usb

10 comments

I am trying to get to full robotic with control from a PC for startup to shutdown. I’m using a smart plug to switch on power to each device but the PC power is always on. I can switch off the dome power supply but the controller board stays on because of the USB.

So 1) i didn’t like the idea of the board staying on at all times due to daytime heat, but will it survive?

2) If I disconnected 5V from the Vcc bus from the PC by just cutting red line in the cable, so that the board is powered only if main supply is on, Will USB port still communicate? Or does it need Vcc+5 to the port to allow Tx/Rx.

Nov 18, 2018

The Arduino board can be powered by either the +5V USB connector or the +12V power supply; so in order to actually power it down you must cut both the 12V supply and the USB connection. Your best bet is to place a powered USB hub between the rotator and your PC. This will allow you to cut power to both the 12V power supply and the USB connection.

Nov 18, 2018

Thanks. I havent even able to find a USB hub that’s also wont take power from the PC. I’ll look for one.

Nov 18, 2018

Hi! Like I said I use a powered hub and switch both it and the dome 12V off with a web power switch. You will find that the rotator will need rebooting that way once a day or so to be stable. For me it's off every AM then back on an hour before sunset etc.. I have no clue about cutting wires and such!

Now you can set the BIOS in most PC's to "boot on powerup". That means you can shut it down and kill power. Then remotely power up and it's running again. I do that as no way I'd leave the little NUC running 24/7 in summer heat especially.

 

Best,

Ron

Nov 19, 2018

how Do you reboot the rotator, just disable/ enable in device manager?

Nov 19, 2018

@dave4robots

 

Connect the power supplies for both the Rotator 12V and the USB 3 hub to the same "smart switch." Then, when you power cycle the switch, the rotator will start from a fully-off state, i.e., it will reboot.

Nov 20, 2018Edited: Nov 20, 2018

I have "totally" remote. I can power up image and shut down from the house or anywhere with a internet connection. To power switch I use the digital loggers wireless switch. (Babak sells in the automation link of this site). To depower (I read its your USB?) why is the computer running? I run a nuc and power it down as well with the digitial logger. (it has 6 switched outlets). It's clear your problem is the PC is always on? (why?) If you wish to talk about totally remote setup... contact me on fb or in a group I created for remote imagers https://www.facebook.com/groups/603823309998136/

 

 

 

 

Nov 20, 2018

That’s a beautiful set up. Have I also seen those pictures on cloudy nights? (I’m Romadave there)

 

My PC is kind of not the prob actually. It sits in a control room closet to stay out of the elements. I have a powered USB hub that also extends hdmi for a screen in case I need it during setup. The hub is powered over Ethernet from the schools network switch so I can’t turn it off. I think putting the powered is better hub mentioned above in the path will let me control connection via power strip.

 

If if I can’t get that working I’ll seeing more advice. Thanks everyone!

New Posts
  • This is the process i go through to get to the speed settings for the shutter, so a few questions: First I open ascom dome control panel I click connect. Of course it doesnt let you change values unless its disconnected, so i disconnect and reopen the nexdome ascom server monitoring window, hit setup: Seems no matter what values i put below, here 600/1500 etc, the speed of the shutter is the same. I had tried lowering these at first to see if it would help with the motor sticking. Is this the right procedure to lower the values and test? Also, i know there is a much longer thread here about updating the firmware on the shutter/rotator, but, what does the update firmware button here do? At one point i clicked it when only the rotator was connected, it claimed it updated? How do i know if i even need to update either? Both came brand new recently? Thanks in advance
  • I've completed the motor install (although i may be missing parts on the motor related to this, the set key that holds the pin in place was missing, found an m4 for now that seems to hold it but the pin doesnt go in fully, see this thread for more details) https://www.nexdome.com/forum/observatory-automation/shutter-motor-missing-key-set-screw-locking-pin-wont-go-in-fully-track-shredding First issue (or maybe not), when i push the motor and it moves up, i think when the panel that has the band through it goes under the first panel, half way up, it sticks for a half second, flexes and pops and keeps going. After this at times on the way up, even during the first half, sometimes the motor stalls briefly. The biggest issue is after its up fully and you bring it down, the first 16" or so going back it stalls and moans repeatedly, however, interestingly i can work it forward by doing an on off real quick multiple times, OR by pressing upward on the motor. Here is a video clip of the stalling (most of it near the end): https://www.youtube.com/watch?v=nCtvALmB6zU At this point i took all the wheels off the rear, added washers, so now they have quite a bit of flex available. The retention bracket is installed, but i had my son work the motor while i pulled back on the bracket and wheel on one side only, no change. When you pull the panels in the rear when its up there, apart, you can see grinding marks on each panel on the sides. So at this point i'm left with removing the retention brackets on both sides as a final test, and to be able to get the panels apart to add antifriction tape someone recommended. It appears the front panels will need to come off (not the rear solid non moving one), then apply tape as here: Here is an external view of the situation: https://www.youtube.com/watch?v=rNHI3KzOkbw This is the antifriction tape i've ordered (1" x 15 feet, two rolls,TapeCase 423-5 UHMW) : https://www.amazon.com/gp/product/B00823JF0S/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 I dont know what else to try, other than what i have planned at this point. Pretty frustrated. Incidentally, i have the inside dome rotation working pretty solidly, so this is the only sticking point, pun intended. Thanks in advance.
  • Im breaking my shutter issues into multi parts here, in this one, i seem to be missing the set screw on the part by the gear as in this image: The part circled was naturally coming out. I'd like to get the official part to fix this, however in the meantime i've added what seems to mostly fit but not flush, m4 set screw and the locking pin goes in a tad further: Any suggestions here? From someone else, it appears that pin should slide all the way inside (i dont know if this could be related to the motor stalling/sticking issue i have (sep thread))