CONTACT US

BE FIRST TO KNOW

Questions? Comments or like to contact us? Use this form to message us.

Email: sales@nexdome.com

Tel:    +1.604.421.2835

Sign up for our newsletter to get informed about NexDome news or new products.

Oct 2, 2018

Shutter motor - how do I make it run?

74 comments

Ok, dumb question, but I'll ask. I installed my motor on the shutter and hung the changer on the magnetic contacts. At first I though the battery might be too low for the charger to do it's thing, but then I measured the voltage across the contacts and found 12.7 volts. So there is a charge on it. I'm still in the install process, and was trying to manually run the motor to get a few inches of the track rolled into it so I could mount that on the dome. I do have the power connector plugged in too, but nothing happens when I push the rocker switch. I don't have any magnets or dome rotator installed yet (I had the familiar double side tape issue - another topic!), so not sure if I'm missing something that needs to be in place?

 

 

Oct 2, 2018

Hi Tom,

When my kit arrived I had the same issue. Take off the 4 little screws to remove the shutter cover. I'll bet you see exactly what I saw!! There will be a pair of spade connectors for the batter not connected. Certainly you can verify this without removing cover. Just pull off the little plug cable on top and measure volts there. If it's zero (as I'll bet) the battery is not yet connected.

Good luck!

Ron

Oct 2, 2018

Hi Again Tom.

Now if the battery is indeed connected (er uh your volt meter suggests that thinking about what I said)..

You should not have to do anything. Make sure power is going to the rotator arduino (just USB). Wait 20 sec and try the rocker switch on shutter again. Should not need anything really except power in the shutter. I'm as mystified as you.

 

I'm not a Facebook fan but I did sign in just for the NexDome group. Looks like there is a lot of support there. On this forum good support from NexDome folks appears but it might take a couple of days.

Ron

Oct 2, 2018

Thanks Ron. I'll try pulling that off the shutter and peek at the guts. Maybe check the voltage at the connector first to see what is coming out of that. I didn't try powering up the rotator, but maybe they need to talk to each other more than we think. I figured that maybe the rocker would have an immediate response, but I could be wrong.

When I had it on the charger and the plug connected last night, I could see an LED blinking on the board.

Yes, I'm on the Facebook group as well as the DIY Home observatory site. I've been posting my progress and getting a lot of good tips there too. Just wish it was more searchable like a forum like this is. At least there is a huge following there for quick ideas or comments.

 

Tom

Oct 2, 2018

rocker might take a few sec first time. For sure pull the plug off the top and measure power there. That's the input for the board. Mine required opening and connecting two spade connectors.

 

Best,

Ron

Oct 2, 2018

Ran outside in the rain with my voltmeter to check. Found volts in both places. I'll have to try with the rotator nearby maybe.

 

Oct 3, 2018

The FB group has a search on the left side. there is a box and a little magnifying glass. That will help.

 

Oct 3, 2018

True, and there is a huge following in there. It's just easier to organize comments and topics in a forum. We need encourage more people to come over here.

Tom

Oct 4, 2018

I agree with Tom. I will never ever (and never have) use FB .. ever ...

I don't work for NexDome but I'm the one who designed the current Arduino shield used in the rotation and shutter controller. I also wrote the X2 plugin for TheSkyX Pro and know a fair amount about all existing firmwares. So most of the core knowledge is in this forum, not on FB.

 

Oct 4, 2018

Awesome Rodolphe!

It is nice to meet you!! I agree with your FB sentiments. While Pat's 0.5.3.2 works quite well with my automation (ACP) I do see things which need refining. My plan is to wait until the next build before diving into the code.

Thank you for being here and all that you have done to make this project a winner.

Ron

Oct 4, 2018

Here is an update on my troubleshooting. First, when looking closer at the boards, I did notice that there was no nuts on any of the supporting bolts. The board was half pulled out when I opened it, as well as the black controller box wasn't straight. Reseated both, I did update the firmware to 0.5.3.2 and it worked with no errors (I'm *extremely* careful with that USB connector!). TX/RX LEDs blinked when uploading. ASSOC LED is lit but not flashing, as well as the Power and L indicators.

When I toggle the rocker, I can hear a faint "hissing, static" or a faint noise in the motor. Also feel a little "bump" when actuating it. It is trying to move, but not. Any ideas what voltages I should bee seeing in various places? Seems that I'm very close, but missing something.

 

Wire connections, and you can see the missing nut on the post at the bottom left. They are all like that, so I wonder if it jiggled out of place during shipping since it has no support?

 

 

 

Oct 4, 2018

fb has a lot of positives. You can "hide your account from all" and use it only for the group. The best part is it's nearly real time - we have live conversations and assisting sessions. When someone posts a problem or question, everyone is notified and if online - you'll get an instant reply. Im' not a fb "user" really. I use it for communication to friends/family. Forums feel lonely. (like now, I feel I'm the only one here and someone might see this eventually).

Oct 4, 2018

@Tom :

There should be nuts on these to hold the whole thing together ...

Check the power on the blue connector in front of the VCC/GND label on the black box (the black box is the stepper controller). You should get 12V there. and check on the stepper controller screws to check that you also get 12V there (aka this make sure the pin are properly soldered).

Also what is the configuration on the dip switches on the side of the stepper controller (black box) ?

 

@Ron : I will not go on FB.. no need to continue discussing this.

Oct 4, 2018

Nothing was screwed down other than the Arduino board. Someone must have run off to lunch and didn't finish this one?

I'll check that for 12v next and see what I find. I did pull off the red Nexdome board and checked the solder connections. They did all look good - and trimmed. I saw someone had an issue on CloudyNights with un-trimmed and some cold or minimal solder joints.

Switches are 2 and 6 ON (down).

 

 

 

Oct 4, 2018

Ok, the dip switches seem ok :

1 - off

2 - on

3 - off

 

8 microstep -> Ok

 

4 - off

5 - off

6 - on

 

2.8 Amp limit -> Ok.

 

 

Oct 5, 2018

Found 12.5v where it should be found. Not sure what I did or bumped but the rocker now works. Motor turns as it should now! Maybe a screw was loose and only had a partial contact?

Ok, moving forward with the radio part...still no contact with the rotator/ASCOM which still has me stumped.

Oct 5, 2018Edited: Oct 5, 2018

Yep. Make sure the screw are tight on the stepper controller as it could explain what you saw.

For the XBee issue you could connect a usb cable to the shutter controller and issue a few manual commands from a serial terminal (something like CoolTerm) to see if we can get the 2 controller to talk to each other. If you connect to it at 9600 baud, 8bit data, no parity, 1 bit stop and issue a H (followed by enter) and see if this triggers something.

Oct 5, 2018

Thanks, I'll try CoolTerm and see what happens.

 

Oct 5, 2018

Looks like they are talking to each other. Tried CoolTerm also, just since I wanted to see what that looked like.

 

Oct 5, 2018

@Tom Gwilym

So does the driver reports the shutter as connected, its position as well as the current voltage level of the shutter battery ?

Load more replies
Oct 5, 2018

If I recall right - I used the arduino software to send terminal commands directly. It's the icon top right in the Arduino application.

Oct 5, 2018

Yep, that should work to. Thanks Ron.

Oct 5, 2018

Thanks! Sounds like I have the software I need without installing more. I'll just be careful again with that USB connector. I have the cover off so I brace the thing with one finger while plugging it into that tiny connector. ;-)

 

Oct 6, 2018

Connecting terminal directly to the rotator I get the following.

Not much other than it's seeing it. I did notice low voltage reading in the settings page, but since the rotator is connected to 12v maybe it's not as critical as the battery shutter motor?

I can rotate the motor using the directions in "settings" but no the Poth Goto a heading. I get an "error attempting to slew" message.

The Assoc LED on the shutter isn't blinking either - but the rotator's is.

Just keeps getting more strange.

 

 

Oct 6, 2018

This low voltage is weird and will prevent this from working right as it's bellow the cut off value.

The rotator does check the rain sensor so that's fine.

If you send a H# command does it do anything

Ideally, if you can, it would be good to have a usb cable on the rotator and one on the shutter to test things from CoolTerm with 2 connection open. Sending H# to the rotator, if it talks to the shutter via the XBee should trigger something on the shutter usb output.

Oct 7, 2018

Both on the computer via USB connector and switching devices by changing com port.

 

 

Rotator:

H - Rotator says hello!

Sending hello

Sent hello back

Asking for rain status

 

Shutter:

H - %Rotator sending Hello#

v- v0.5.2.3#

...and so on when trying the different commands.

 

 

 

 

Oct 6, 2018

I agree the low voltage is very weird but I see the exact same thing! I set the threshold to 1V and everything has run perfectly for several nights now. I was asked to check 3 voltage divider resistor connections on the rotator board and they were fine. I need to change the 12V rotator supply.. it has a strange flashing green led. my other 5A 12V supplies do not have plugs with a large enough center post hole and I need to make an adaptor to rule out the supply. I'm guessing another possiblity is that with the 5.3.2 firmware maybe the wrong pin is being read? Yes it is weird indeed. I'm not inclined to tear things apart looking in my case because it all works very well here in Texas. Eventually will look at code but for me ACP automation is very robust. I do see things in the ascom driver I do not like.. eg if acp homes the dome there is never a response back saying it happened.. So I would "stop motion" (it's sitting at home not moving) then click same button in acp again and it's ready to go. Fortunately manually homing in acp is never part of a workflow.

Thank you Tom for your patience and hard work and thank you Rodolphe for being a hand of guidance so we all can learn.

Ron

Oct 6, 2018

I used the github version of the 5.3.x firmware and as I'm the one who designed the shield and wrote the X2 plugin for TheSkyX Pro I was able to make sure the reported voltage was correct after I applied some math correction in my plugin as the one in the firmware is somewhat wrong and reports higher value than what it is ( see https://rti-zone.org/macosx_x2dome_plugins.php#nexdome ).

But 4.80V way out of the expected value but as long as the cutoff is bellow that number you should be fine.

I also noticed that the firmware has debug enabled.. this can also cause problems (my plugin for example doesn't like the debug lines). If you uploaded the plugin from the source, change this :

byte debugEnabled = 1;

to :

byte debugEnabled = 0;

 

line 72 in RotatorClass.h, then recompile and re-upload the firmware.

 

Oct 6, 2018

Wow thank you Rodolphe! I think we are all going to have to gain at least a basic understanding of how to use Github in order to advance.

Best,

Ron

New Posts
  • This is the process i go through to get to the speed settings for the shutter, so a few questions: First I open ascom dome control panel I click connect. Of course it doesnt let you change values unless its disconnected, so i disconnect and reopen the nexdome ascom server monitoring window, hit setup: Seems no matter what values i put below, here 600/1500 etc, the speed of the shutter is the same. I had tried lowering these at first to see if it would help with the motor sticking. Is this the right procedure to lower the values and test? Also, i know there is a much longer thread here about updating the firmware on the shutter/rotator, but, what does the update firmware button here do? At one point i clicked it when only the rotator was connected, it claimed it updated? How do i know if i even need to update either? Both came brand new recently? Thanks in advance
  • I've completed the motor install (although i may be missing parts on the motor related to this, the set key that holds the pin in place was missing, found an m4 for now that seems to hold it but the pin doesnt go in fully, see this thread for more details) https://www.nexdome.com/forum/observatory-automation/shutter-motor-missing-key-set-screw-locking-pin-wont-go-in-fully-track-shredding First issue (or maybe not), when i push the motor and it moves up, i think when the panel that has the band through it goes under the first panel, half way up, it sticks for a half second, flexes and pops and keeps going. After this at times on the way up, even during the first half, sometimes the motor stalls briefly. The biggest issue is after its up fully and you bring it down, the first 16" or so going back it stalls and moans repeatedly, however, interestingly i can work it forward by doing an on off real quick multiple times, OR by pressing upward on the motor. Here is a video clip of the stalling (most of it near the end): https://www.youtube.com/watch?v=nCtvALmB6zU At this point i took all the wheels off the rear, added washers, so now they have quite a bit of flex available. The retention bracket is installed, but i had my son work the motor while i pulled back on the bracket and wheel on one side only, no change. When you pull the panels in the rear when its up there, apart, you can see grinding marks on each panel on the sides. So at this point i'm left with removing the retention brackets on both sides as a final test, and to be able to get the panels apart to add antifriction tape someone recommended. It appears the front panels will need to come off (not the rear solid non moving one), then apply tape as here: Here is an external view of the situation: https://www.youtube.com/watch?v=rNHI3KzOkbw This is the antifriction tape i've ordered (1" x 15 feet, two rolls,TapeCase 423-5 UHMW) : https://www.amazon.com/gp/product/B00823JF0S/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 I dont know what else to try, other than what i have planned at this point. Pretty frustrated. Incidentally, i have the inside dome rotation working pretty solidly, so this is the only sticking point, pun intended. Thanks in advance.
  • Im breaking my shutter issues into multi parts here, in this one, i seem to be missing the set screw on the part by the gear as in this image: The part circled was naturally coming out. I'd like to get the official part to fix this, however in the meantime i've added what seems to mostly fit but not flush, m4 set screw and the locking pin goes in a tad further: Any suggestions here? From someone else, it appears that pin should slide all the way inside (i dont know if this could be related to the motor stalling/sticking issue i have (sep thread))