Questions? Comments or like to contact us? Use this form to message us.


Tel:    +1.604.421.2835

Sign up for our newsletter to get informed about NexDome news or new products.

May 20

Shutter USB for firmware where


Total stupid question but is the shutter USB a micro or something on top of the unit? I see a hole with a 9red LED light. but Is that little USB the correct one?


Just making sure sure I have this right. You have to connect to the shutter Arduino board directly to update the firmware?


I tried connecting to rotator board board and that didn’t locate shutter.


And as of now which shutter firmware version should I use that works best? The one on github Nexdome automation page?


May 21

The Arduino Leonardo present in both controller use a Micro USB port.

You do need to connect to the Shutter Arduino via usb to update its firmware.

You should use the latest firmware from

At least until the new firmware from Tim comes out (and there will not be a X2 plugin for it for a while as i need to do a brand new plugin as all commands have been changed and some feature are different ).



So connect as ascom dome in TheSkyX? And thanks for the USB clarification.

May 21


"So connect as ascom dome in TheSkyX?" -> no, you can't update the firmware with TSX.


You need the Arduino IDE to load the firmware on the Arduino.

Make sure you get the right version (2.12 is the version in the git repo).

So connect first to the rotator Arduino, load the Rotator.ino in the Arduino IDE, select the right board (Arduino Leonardo), compile and upload the firmware.

Repeat the same procedure with the shutter Arduino (with Shutter.ino and a usb connection to the shutter Arduino)

@Rodolphe I meant after updating the firmware in Arduino, will I have to connect the dome add on in TheSkyX as an ascom dome instead of native Nexdome x2 driver to work with the newest firmware and shutter?

Load more replies
New Posts
  • This is the process i go through to get to the speed settings for the shutter, so a few questions: First I open ascom dome control panel I click connect. Of course it doesnt let you change values unless its disconnected, so i disconnect and reopen the nexdome ascom server monitoring window, hit setup: Seems no matter what values i put below, here 600/1500 etc, the speed of the shutter is the same. I had tried lowering these at first to see if it would help with the motor sticking. Is this the right procedure to lower the values and test? Also, i know there is a much longer thread here about updating the firmware on the shutter/rotator, but, what does the update firmware button here do? At one point i clicked it when only the rotator was connected, it claimed it updated? How do i know if i even need to update either? Both came brand new recently? Thanks in advance
  • I've completed the motor install (although i may be missing parts on the motor related to this, the set key that holds the pin in place was missing, found an m4 for now that seems to hold it but the pin doesnt go in fully, see this thread for more details) First issue (or maybe not), when i push the motor and it moves up, i think when the panel that has the band through it goes under the first panel, half way up, it sticks for a half second, flexes and pops and keeps going. After this at times on the way up, even during the first half, sometimes the motor stalls briefly. The biggest issue is after its up fully and you bring it down, the first 16" or so going back it stalls and moans repeatedly, however, interestingly i can work it forward by doing an on off real quick multiple times, OR by pressing upward on the motor. Here is a video clip of the stalling (most of it near the end): At this point i took all the wheels off the rear, added washers, so now they have quite a bit of flex available. The retention bracket is installed, but i had my son work the motor while i pulled back on the bracket and wheel on one side only, no change. When you pull the panels in the rear when its up there, apart, you can see grinding marks on each panel on the sides. So at this point i'm left with removing the retention brackets on both sides as a final test, and to be able to get the panels apart to add antifriction tape someone recommended. It appears the front panels will need to come off (not the rear solid non moving one), then apply tape as here: Here is an external view of the situation: This is the antifriction tape i've ordered (1" x 15 feet, two rolls,TapeCase 423-5 UHMW) : I dont know what else to try, other than what i have planned at this point. Pretty frustrated. Incidentally, i have the inside dome rotation working pretty solidly, so this is the only sticking point, pun intended. Thanks in advance.
  • Im breaking my shutter issues into multi parts here, in this one, i seem to be missing the set screw on the part by the gear as in this image: The part circled was naturally coming out. I'd like to get the official part to fix this, however in the meantime i've added what seems to mostly fit but not flush, m4 set screw and the locking pin goes in a tad further: Any suggestions here? From someone else, it appears that pin should slide all the way inside (i dont know if this could be related to the motor stalling/sticking issue i have (sep thread))