CONTACT US

BE FIRST TO KNOW

Questions? Comments or like to contact us? Use this form to message us.

Email: sales@nexdome.com

Tel:    +1.604.421.2835

Sign up for our newsletter to get informed about NexDome news or new products.

Mar 4

AstroBerry automation

2 comments

Edited: Mar 4

Since we have several discussions going on, I thought I would start a new thread to keep things organized.

I've been experimenting with Raspberry Pi 3 B+ using the AstroBerry OS on it. I haven't gotten to the dome control yet, but I did get the rotater rotating with INDI using Astronomy Linux when testing that on my tower computer (also on the "bench" since it's too cold and dome is iced up these days - waiting for some "spring" to happen!).

I've been impressed with what I've seen in the features of AstroBerry and hoping to work out the dome functions with it. Again, I'll admit that I haven't really tested it yet, but know there is some interest in it. My goal is to get it all working, run the observatory and imaging on it, and be free of Win 7.

 

Tom

 

 

FAIRLY good luck recently. While I had some issues getting the devices on the NUC to connect with Kstars and Ekos, I pulled the plugs and put them into the PI. It's sitting out there now.

At first I ran kstars and ekos on the PI - (not the best idea, it's not a fast machine and lack of ram meant it crashed to OS a lot). Solution? I started the web server on it so it has nothing to do but interface and communicate to my devices.

I then am running (Linux vers) though windows Kstars would work as well. This allows me to have the power of my desktop running all the software and processing solves... while the PI handles the IO. It's worked much better. The pi connect almost all my devices. I am havine a problem connecting the Cloud Watcher, the Pyxis rotator. But I have connected foxlynx focuser 1 and 2 nexdome AstroPhysics mount Astrometry snapcap 1600mm lodestar ASI EFW This morning I was testing and I had the snapcap closed. If I open it it hit my dome and jams. So I always do it when the shutter is open. ANYWAY- I fire up the 1600 for a test and when I did the snapcap opened. (camera just tell it) Impressive... and it jammed. I got it fixed up but interesting

to see how all this stuff works together. I can even load a previous saved fits - and it will load it and slew to it. - I've amazing so I'm really pushing to make the change. The BIG problem for me now is getting the shutter to connect to the rotator. (Xbee?) I dunno. This has happened ever since I got the shutter. Pat's firmware seemed to make it happen (not sure why) but I had to go back to nexdome 1.1 for the INDI nexdome driver and it has worked once. Now won't connect. = ( So glad it's cloudy because the delay would drive me nuts.

 

Great work! I was explaining Linux to you no long ago, and now you seem to be well on your way. :-)

Despite the connection issues you mentioned, the 1.1 firmware for the motors is the one to use on EKOS? That's the version that is listed on the "support" page of Nexdome site?

I did install Kstars / INDI on my laptop so I'm going to try out the Pi / Astroberry server mode and see how that works.

One more question...not sure if you have platesolving working yet, but if you have gotten that working, can you keep the Astrometry files on the client computer or does it have to be on the Pi server side? (Otherwise just do the online where it uploads the image, but that takes a bit longer).

Tom

 

New Posts
  • This is the process i go through to get to the speed settings for the shutter, so a few questions: First I open ascom dome control panel I click connect. Of course it doesnt let you change values unless its disconnected, so i disconnect and reopen the nexdome ascom server monitoring window, hit setup: Seems no matter what values i put below, here 600/1500 etc, the speed of the shutter is the same. I had tried lowering these at first to see if it would help with the motor sticking. Is this the right procedure to lower the values and test? Also, i know there is a much longer thread here about updating the firmware on the shutter/rotator, but, what does the update firmware button here do? At one point i clicked it when only the rotator was connected, it claimed it updated? How do i know if i even need to update either? Both came brand new recently? Thanks in advance
  • I've completed the motor install (although i may be missing parts on the motor related to this, the set key that holds the pin in place was missing, found an m4 for now that seems to hold it but the pin doesnt go in fully, see this thread for more details) https://www.nexdome.com/forum/observatory-automation/shutter-motor-missing-key-set-screw-locking-pin-wont-go-in-fully-track-shredding First issue (or maybe not), when i push the motor and it moves up, i think when the panel that has the band through it goes under the first panel, half way up, it sticks for a half second, flexes and pops and keeps going. After this at times on the way up, even during the first half, sometimes the motor stalls briefly. The biggest issue is after its up fully and you bring it down, the first 16" or so going back it stalls and moans repeatedly, however, interestingly i can work it forward by doing an on off real quick multiple times, OR by pressing upward on the motor. Here is a video clip of the stalling (most of it near the end): https://www.youtube.com/watch?v=nCtvALmB6zU At this point i took all the wheels off the rear, added washers, so now they have quite a bit of flex available. The retention bracket is installed, but i had my son work the motor while i pulled back on the bracket and wheel on one side only, no change. When you pull the panels in the rear when its up there, apart, you can see grinding marks on each panel on the sides. So at this point i'm left with removing the retention brackets on both sides as a final test, and to be able to get the panels apart to add antifriction tape someone recommended. It appears the front panels will need to come off (not the rear solid non moving one), then apply tape as here: Here is an external view of the situation: https://www.youtube.com/watch?v=rNHI3KzOkbw This is the antifriction tape i've ordered (1" x 15 feet, two rolls,TapeCase 423-5 UHMW) : https://www.amazon.com/gp/product/B00823JF0S/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 I dont know what else to try, other than what i have planned at this point. Pretty frustrated. Incidentally, i have the inside dome rotation working pretty solidly, so this is the only sticking point, pun intended. Thanks in advance.
  • Im breaking my shutter issues into multi parts here, in this one, i seem to be missing the set screw on the part by the gear as in this image: The part circled was naturally coming out. I'd like to get the official part to fix this, however in the meantime i've added what seems to mostly fit but not flush, m4 set screw and the locking pin goes in a tad further: Any suggestions here? From someone else, it appears that pin should slide all the way inside (i dont know if this could be related to the motor stalling/sticking issue i have (sep thread))